• How to make a default selection for the Time Zone property

    DescriptionThis KB article shows how to make a default selection for the Time Zone property or remove it from being a required field when editing a user. ResolutionTo make a default selection for the 'time zone' user custom property:  Go to Workarea > Settings > Configuration > Custom Properties to display the View User Custom Properties screen.Select the Time Zone property. Inside the list here is a check box that says first option is not a valid selection. This will stop t...

  • How to setup the ContentAwaitingApproval widget on the Smart Desktop

    DescriptionThis KB article shows how to setup the ContentAwaitingApproval widget on the Smart Desktop of the Workarea. ResolutionChoose Workarea > Settings > Configurations > Personalizations > Widget Space > Edit UserSmartDesktop .Select all for all widgets and then click Save Widget Space .Choose Workarea > Desktop .Click the little carrot on the right side to Add Tab to open a drop-down menu.Drag ContentAwaitingApproval into the space below. You should notice imme...

  • How To: Viewing a “Desktop” Website on a Mobile Device

    DescriptionIs it possible to view the full version of your website from a mobile device? How can you load that up instead of the mobile version? ResolutionTo provide the “full site” experience on a mobile device, the device’s browser cookies must store device information for the “Generic Device” group, (as opposed to a mobile device group). The following method shows how to redirect a mobile device user to the default.aspx page (where the “full site” version of your website is located) ...

  • HTML Form Reports do not save as .XLS format

    DescriptionPrevious to applying CU 24 (or later) to your 9.00 SP2 site, when you exported an HTML form report you could not save the file in MS Excel format (.xls).  ResolutionThis is intended functionality and was implemented in culmative update 24. It resolved a conflict with errors when opening the file in MS Excel 2010 and 2013.Either use an appropriate application to open the .HTML file, or you can try to simply change the extension type to .XLS and attempt to open the file in MS E...

  • InboundWriter Error: Something Unexpected Happened

    DescriptionWhen you try to do the InboundWriter Analysis, the InboundWriter dialog returns an error as follows:Oops, Something Unexpected Happened! ResolutionThere is an error from InboundWriter site processing your content. To work around it, you can try publishing the content first and re-edit to try InboundWriter again.If this keeps happening, follow the instruction on the error dialog.

  • Input string selector when using a resource selector to select unpublished content items based on taxonomy category

    Description When using the resource selector to select content items there is a known issue with finding items based on the taxonomies that they are assigned to. If the taxonomy has items that have never been published assigned to it the resource selector popup will thrown an 'Input string was not in a correct format' when clicked. Resolution This is confirmed to be a known issue within the product, and is patched within site cumulative update 17 for version 9.2 sp1.

  • Input string was not in the correct format error message Appears Inside The Workarea

    DescriptionUpon loading up the workarea, you see an error message on the dashboard with the following message:"input string was not in the correct format"This message may also appear in the Event Viewer Application logs and will typically reference the ContentCheckedOut.ascx.cs file in the "Source File" section of the error.  CauseThere's a number of potential reasons why this error occurs but most frequently it seems to appear when a user backs out of a checked out piece of content.Und...

  • Issue when disabling and re-enabling url aliasing

    DescriptionWhen disabling url aliasing in the system, when you go back to re-activate it you must activate all url aliases again before they will become active. Re-enabling aliasing itself will not activate the aliases. ResolutionWhen in the workarea navigate to Settings > Configuration > Url Aliasing > SettingsEnable the alias types you want to display on the websiteNavigate to Aliases and you will notice they are not marked as active. Check edit and check off the active columnClick Sa...

  • Missing taxonomies after upgrading to 9.10

    DescriptionMissing taxonomies are causing site manipulations to folders after upgrading from 8.60 to 9.10. ResolutionSome of the content items in the menu were in a checked out state during upgrade.Identify content items in the menus that are not showing.Verify that the content items current state is Published.Restart the Web site application pool to clear caching.

  • No endpoint listening within the Workarea

    Description When navigating or editing within the Workarea the following error message is displayed: There was no endpoint listening that could accept the message. This is often caused by an incorrect address or SOAP action. Cause Old server information in the AssetServerTable can cause communication issues and inefficiencies with the CMS. Resolution In the site's database, right-click on the AssetServerTable and click Select top 1000 . Unless load balancing is configu...

  • Numbers appended to alias names

    DescriptionIf you create an alias name that already exists, Ektron adds a number to the alias name (to make it unique).CauseThe system automatically appends a number to prevent duplicate aliases. ResolutionWhen you create an automatic alias, examine the folder or taxonomy structure that were used to form the alias. If the outcome of this rule is similar to another alias rule you might see numerous duplicates. Either adjust the rule or change the folder and taxonomy structure to avoid cr...

  • Option to create a new Smart Form is not showing up in the drop down

    DescriptionThe option to create a new Smart Form is not displayed, even though the folder has an associated Smart Form within the folder properties. CauseThe default template of the folder may be a wireframe template, instead of an .aspx template, which designates that folder as a page layout folder. ResolutionIn the properties of the folder, check the Templates tab to verify that the default template is not designated with a wireframe.Click View on the the folder.Choose Pr...

  • Page not found when using aliases with multisite site aliases

    DescriptionMultisites can have their own unique aliases called site aliases which you set in the folder properties of the multisite folder. In 9.0 SP2 (with no cu's applied) there is an issue where aliases used on content within a multisite will not work when used with the site alias. For example, if your site alias is 'www.multisitealias.com' and a content alias within that multisite is '/content_alias/' then the URL 'www.multisitealias.com/content_alias/' would give a page not found error....

  • Pagebuilder Renders Different Markup For iOS11

    Description This article describes an issue with Pagebuilder rendering incorrectly in iOS11. The difference can be seen in inspector window of the browser. Resolution This issue has been identified in issue EKTR-274 which can be seen in the release notes here.  The recommendation is to update to latest cumulative update or later release to resolve this issue.

  • Pagination not Working in User Settings

    DescriptionIn the workarea's user settings if you edit a user, select the user groups tab, and try to choose the button to change the page, the page control does not respond. This is only an issue if you have sufficient user groups assigned to a user that more than one page of user groups is available.  ResolutionThis issue has been fixed in later versions so you can resolve the issue by applying the latest version . 

  • Problem retrieving community groups after upgrade to 9.10

    DescriptionAfter you upgrade to Ektron 9.10, an error may occur when you choose Workarea > Settings > Community Management and click on Community Groups (see screenshot). The error is caused by retrieving a group at Ektron.Cms.Community.CommunityGroupAPI.GetAllCommunityGroups. ResolutionMake backup of the current database and then apply the following SQL statements. update community_group_tbl set enable_calendar = 0 where enable_calendar is NULL update community_group_tbl set enable_todolist...

  • Problem: In IE 11 the Web Calendar is Shrunk in Workarea

    DescriptionWhen you create and then view a calendar inside the Ektron Workarea, the dates and overall view are shrunk almost like they've been smushed together.Please Note: This issue ONLY occurs with Internet Explorer 11 ResolutionThis issue here lays with IE11 turning compatibility mode 'on' by default. This configuration is unsupported and is known to cause cosmetic and functionality issues. We'll need to disable this in order to "right the ship."Here's how to do this:1. Press Alt/X ...

  • Publish as a PDF Feature is Discontinued

    DescriptionThe "Publish as a PDF" feature does not work. CauseThe PDF generation server is no longer available online. ResolutionSet up a server with a PDF generation service.Note: Ektron does not endorse any particular brand for PDF generation. 

  • Re-indexing Search

    DescriptionIf you're using EPiServer Search for your site, your content needs to be indexed regularly to be searchable. Normally the index is rebuilt on site startup, and on various events like publishing/moving/deleting pages and files. If you need to manually force a full content re-indexing, there is a tool for that.ResolutionBrowse to http://yoursite/EPiServer/CMS/Admin/IndexContent.aspx On that screen you can click the "Start Indexing" button to rebuild the index. There is an option, ch...

  • Repeating folder tree in the Workarea

    Description The main folder tree in Content section of the Workarea repeats when you try to get to a sub-folder. Cause There is a lowercase URL Rewrite in the IIS URL Rewrite tool section(often done for SEO purposes) which is interfering with workarea traffic. For example: <rule name="LowerCaseRule1" enabled="true" stopProcessing="true"> <match url="[A-Z]" ignoreCase="false" /> <action type="Redirect" url="{ToLower:{URL}}" /> </rule> Resolution Applies to all Ektron versi...

  • Reports Not Working after CU Application

    DescriptionIf the 'Checked In Content Report', 'Checked Out Content Report', 'Search Phrase Report', and/or 'New Content Report' are giving a custom error or a compilation exception after applying a CU to 9SP2 you may have an issue where your workflow.ascx file has an incorrect reference.Error: The type or namespace name 'ContentWorkflow' does not exist. Resolution1. Backup the workarea and bin folders 2. Replace them with the equivalent folders in the program files. C:\Program Files (...

  • Resizing Ektron DMS images using query string parameters

    Description When presenting a DMS document on the front end of an Ektron site through the use of querystring parameters. This was first introduced in version 8.5 of Ektron. As a note adjusting a dimension does not automatically preserve either the portion or the resolution of the picture. This is controlled by the EktronAssetServerModule, and customization could be added to the CMS to alter how the image is processed. This would likely require customizing the App_code\CSCode\EktronAsset...

  • Resource Selector Times Out When Loading the Folder Tree

    DescriptionWhen creating a smart form with a resource selector, by default the entire content tree is loaded and it can cause a javascript timeout issue when creating or editing content. CauseThe reason that this happens is that the folder tree is being loaded all at once versus loading only the selected folder. ResolutionIf you experience this issue, or slow load times with the folder tree load when using the resource selector, you will edit the following file in the workarea fol...

  • Restore your deleted content or folder

    Description If a folder or content has been accidentally deleted, here are the steps to bring it back. Resolution Choose one of the following: Restore both sending and receiving databases back to the same time before the content/folder was deleted. Recreate the content/folder in the workarea where it was deleted and then sync. Please note this will create new Folder/Content ID's. Sync from the server that has the content to a min database where the content was deleted. A proac...

  • Sample of regex aliasing with language identifier

    DescriptionYou can leverage Regex to create automatic aliasing within the the CMS. Below is a sample of how to create a regex aliasing rule that redirects to a specific language of the content when the en-AU/ value is entered into the URL of the site. This lets a user enter a specific language identifier, as opposed to adding the appropriate langtype value into the URL. After adding this aliasing rule, enter the URL of SiteRoot/en-AU/TemplateName?id=x to resolve to content item with an Austr...

  • Scheduled Events Not working (go live, archive)

    DescriptionScheduled events (content set to go live or archive) are not executed at the scheduled time. ResolutionWas the event scheduled for the next day? (Applies to older product versions)For example, if an event was scheduled to go live on a Monday, it should set the event for 12:00 A.M. Tuesday at the earliest because of how the Ektron Windows Service reads the events for the day at 11:59 P.M. each night.Is the Ektron Windows Service started?Review this article about how to make su...

  • Setting Trace Enabled to True may cause Workarea issues

    DescriptionIf you set the web.config file's settings as follows, the trace may get placed in the wrong Workarea frame.trace enabled="true" requestlimit="100" pageOutput="true" traceMode="SortByTime" localOnly="true">For example, the trace screen may appear behind the Workarea's folders/taxonomies/collections/menus frame (see illustration below). If the trace screen appears in that frame, it disables all controls and renders the frame useless. ResolutionThe easiest solution is to turn of...

  • Space Characters (%20) in URL Redirect does not work

    DescriptionUsing the Workarea > Settings > URL Redirect functionality does not work when used with %20 space characters. For example, a URL redirect from content%20test.aspx to content.aspx does not work. ResolutionTo fix this, you must have access to the Web server and the rights to edit site files. Comment out the following line of code in ~\Workarea\UrlAliasing\AddEditViewRedirect.aspx.cs (uxOriginalURL.Text.Contains(" ")) return false;  

  • Subjects are not being saved in blog posts when published

    DescriptionSubjects are not being saved in blog posts when published. The following steps reproduce the issue. Create a new blog and Add a Name and Title.Click Subjects .Add Subjects "test2." Click Add Blog .Create a new blog post.Click Summary .Check "test2." Publish the blog post.Edit the content.Click Summary . Notice that no subjects are saved. ResolutionA new key was added to the web.config that changes the blog functionality. ek_enableLegacyBlogFields -Determin...

  • Switching editors breaks HTML with br tags in version 9.00

    DescriptionAn issue occurs with   tags in HTML content, if you changed the editor value from Aloha to eWebEdit400 (aka ContentDesigner) or vice versa in web.config . The issue occurs when you enter the content after the editor change, and click Edit ; the following error appears: The 'br' start tag on line 1 position 44 does not match the end tag of 'p'. Line 1, position 49. Line 1, position 49. Line: 1 Position: <49> at Ektron.Cms.EkXml.XSLTransform1(String XmlDoc, String XsltDoc, Boolean...