-
Description
See below for the settings which will enable automatic backups of the database on syncing.
Resolution
Automatic backups can be enabled here:
Settings > Configuration > Synchronization > Settings
The initial sync setting concerns when you have created a new sync relationship and are doing the first sync.
Full sync is when CMSCore is selected in the sync profile.
Add a backup location for the storage of the .bak files.
-
DescriptionAfter installing version a version 9.2 or higher site on a CMS server that was hosting a previous version of Ektron, the workarea reports that no security certificates are found.
CauseThe certificates for the older sites may interfere with the new certificates generated for the 9.2 sites.ResolutionThe error messages may persist after the security certificates were generated initially. If the CMS still does not recognize the certificates, it is recommended to regenerate the certifi...
-
Description
If you are receiving the below error during eSync check to see if TLS 1.0 is disabled on the server.
The caller was not authenticated by the service.
Error executing strategy 'OnAfterESyncRunErrorFromPeer' remotely. Type 'System.ServiceModel.Channels.ReceivedFault' in Assembly 'System.ServiceModel, Version=4.0.0.0, Culture=neutral'
is not marked as serializable.
Cause
TLS 1.0 is required for eSync to function in versions 9.1SP2(including the latest CU for 9.1SP2...
-
Description.1 duplicate files in either assets, private asset, uploaded images, uploaded files, or templates caused by esync. ResolutionThe short term fix to correcting the .1 duplicate file issue is to delete the .1 and delete the respective knowledge files.If you do not know how to find or delete the knowledge files then please read this knowledge base article on that. Out of sync knowledge filesThe long term solution is to update the windows service to 9.0 or higher. You do not have...
-
DescriptionWhat alias information moves over during a sync with the 9.X branch of the product?ResolutionAuto Aliases
With the 9.X branch of the Ektron product, auto-aliases are regenerated during the sync process. This may cause temporary 404 responses on web pages. As such, it's recommended to set up a web site caching strategy, or to sync during 'off-hours' to negate this known behavior.
While the auto-aliases are regenerated, their aliasing rules are physically synced over. If you see an ...
-
Description
Assets, private assets, uploaded files, uploaded images, or templates are out of sync, not syncing to/from servers, or load balancing correctly.
Resolution
If assets, private assets, uploaded files, uploaded images, or templates are not syncing properly, have .1 duplicates, or are not Ektron load balancing (i.e., replicating), the knowledge files may be out of sync. The best way to fix knowledge files is to rename them (or delete them after making a back up) on both ...
-
DescriptionWhen a database sync is performed, an alias regeneration process is initiated on the receiving server. If the aliases are not regenerating, an update may fix your issue. ResolutionThe below issues are documented for 9.1SP2 and previous versions in the version 9 branch. To address these, upgrade to 9.1SP2 if necessary and apply the latest cumulative site update for 9.1SP2.
Update 5 (November 13, 2015)
23306 - Auto Aliases were not created on production after syncing from autho...
-
DescriptionEsync may experience batch write failures when syncing databases. If that occurs you will see an error similar to the following.Sync (Regular Profile) Errored Out, Error: Ektron.DbSync.Core.RemoteDatabaseSyncException: Database Sync has failed on the remote EWS due to error 'Microsoft.Synchronization.Data.DbSyncException: An unexpected error occurred when applying batch file C:\Program Files (x86)\Ektron\EktronWindowsService40\Database\WebSync_a34ae339f8c1414dbaf1cb0d6525c765\60fe...
-
DescriptioneSync fails when the Ektron Windows Service does not start correctly. Debugging shows an exception reading "Service will retry has error System.InvalidOperationException: Cannot swallow exceptions for methods with non-null return type". ResolutioneSync or other service failure with "Cannot swallow" exception in logs.
The Ektron Windows Service reads the web.config files of the sites installed locally in IIS. If one of the URLs in the config file is wrong...
-
DescriptionYou should purge content on Akami CDN after Sync. ResolutionThis documentation should work the same for eSync Strategies because we have CMS Extension described in the following link. http://documentation.ektron.com/cms400/v9.00/Reference/Web/Developer/extension.htmYou should use an extension to call the Akamai APIs to purge cache information. The following video links shows you how to build an integration into Akami via a CMS extension (plugin) for forward caching capabiliti...
-
DescriptionWhere are the cloud management knowledge files ResolutionThe cloud knowledge files are located on the local serverThe amazon knowledge files are located on the sync folder called sitename.s3.amazonaws.com, for example c:\sync\Randyv87sp2engtest.s3.amazonaws.com. The knowledge files will be called, bolbsync.id and knowledge.metadata for the cloud folders and filesync.id and knowledge.metadata for the local system.The amazon knowledge files for are in their respective folders t...
-
DescriptionThe following errors are caused by missing or incorrectly applied certificates.Click on sync profile and the
Uh ohh
error appears.
Cryptography error : Exception Details: System.Security.Cryptography.CryptographicException:
The parameter is incorrect.
Sync gets all the way to the end but then fails.
Identity Check error: Exception Details: System.ServiceModel.Security.MessageSecurityException: The identity check failed for the outgoing message.
No s...
-
DescriptionWhen disabling TLS 1.0 some functionality does not work, including esync.ResolutionUpdate: 5/17/2017
Version 9.2 also has this fix so you can go directly to that version instead of 9.1SP3.
Update: 4/22/2016
Engineering has added this fix in 9.1 SP3. Please upgrade to this version to benefit from this change. Support also has a fix for 9.1 SP2. Currently these are the only two versions that will have this fix. We are investigating adding this to 9.0 SP3 as well. Please contact us i...
-
DescriptionWhat is the Conflict Resolution policy and how does it work? ResolutionThe conflict resolution policy is applied when a file on both sides of the sync relationship was updated between syncs. For example, there is an hourly sync. A sync occurred at 10:00 AM and completed shortly thereafter. The file on both sides was updated between the completed 10:00 am sync and the 11:00 am sync.The conflict resolution policy updates the content on one side, depending on the choices selecte...
-
DescriptionWhen setting up a sync relationship between two servers that have multisite, a site dropdown option becomes available that is not present without multisite. This site dropdown can be the difference between content moving or not. ResolutionFor the first sync which creates a sync relationship between servers make certain to select the "all folders" option in the site drop down. After the sync completes for the "all folders" site option you can create additional ...
-
DescriptionWhat is the Ektron L4 log in the Event Viewer > Application and Services Logs used for? ResolutionThe Ektron L4 log is a good log to check if you're attempting the following:Want to know if the Ektron Windows Service is startedGenerating certificates and the site, or multiple sites, don't appear the site dropdownAttempting to register a site with Solr or Microsoft Search and receiving an error regarding the Ektron Windows Service or 8732Receiving an error message that the ...
-
DescriptionUsing the 9.1SP3 base installer to update an EktronWindowService from 9.X to 9.1Sp3, causes the certificates to be invalid. This may result various errors as seen in this article: /KB/10498/ ResolutionAs a work around, in the Ektron.ASM.EktronServices40.exe.config, find these three bindings: wshttpSyncCommunicationScheduleService, wshttpSyncQueueService, and wshttpScheduleServiceBinding.In the message section within those, change the negotiateServiceCredential from false to ...
-
DescriptionBelow are the steps to enable Ektron Windows Service logging.Resolution8.0 - 8.02SP5
Edit the following file: C:\Program Files (x86)\Ektron\EktronWindowsService30\Ektron.ASM.EktronServices30.exe.config.
Change DebugEnabled to 1.
Open Windows Services.
Stop and start the Ektron Windows Services 3.0.
The log files can be found here: C:\Program Files (x86)\Ektron\EktronWindowsService30\log.
8.5 and higher
Edit the following file: C:\Program Files (x86)\Ektron\EktronWindowsService...
-
DescriptionThe Ektron Windows Service (EWS) has been running without problem but suddenly eSync will not run, and it is soon discovered that the EWS is not starting. CauseThe EktronL4 event log has reached the maximum log size and its properties have been set to Do not overwrite events (Clear logs manually) . ResolutionOpen the Event viewer.Expand the Applications and Services folder.Right-click on the EktronL4 log and select Properties.In the
When maximum Change the event log s...
-
Description
Having a fully started Ektron Windows Service helps ensure that your CMS is functioning properly. In some cases the Ektron Windows Service shows as started in the Windows Services window but is actually not fully started. Here is how to confirm that it is fully started and what to do if it is not.
Resolution
NOTE: When you need to interact manually with the Ektron Windows Service (EWS), you should "Stop" and "Start" EWS (versus choosing to "...
-
Description
Sometimes an esync issue may require deeper logs than what the Ektron Windows Service provides. In those cases, the Sync Framework Trace logs will be useful for gaining extra information during eSync errors, such as: System.ExceptionThis is a much higher level of logging so ensure there is sufficient space on the drive before doing this. It will also increase CPU usage on the next sync.
Resolution
To enable sync framework logging add the below tags just before the...
-
Description
If at the end of a package sync you see the following error, see the below resolution.
Exception of type 'System.Exception' was thrown.
Resolution
This may be a problem with how many items are included in a package sync. You may only have one taxonomy in a package, but if it has 100,000 items in it you could see this issue.
To verify if the sync failure is due to the number of items, do the following.
Enable sync framework logging on both sides of the sync
...
-
Description
Are you seeing the following error despite being absolutely certain you generated security certificates correctly and the service is showing as fully started?
Error generating security certificates. Please make sure that the security configurator has been run and that your security certificates have been properly configured. This issue may also occur if the Ektron Windows Service is not currently running.
If so check your event viewers Windows Logs > System/Security logs ...
-
Description
If sync is giving the following remote endpoint error and you have already done the steps in the wsrm:identifier KB, check the Ektron Windows Service logs.
The remote endpoint no longer recognizes this sequence. This is most likely due to an abort on the remote endpoint. The value of wsrm:Identifier is not a known Sequence identifier. The reliable session was faulted.
If upon checking those logs you find the following error, see below for the resolution.
System.Data.SqlClie...
-
DescriptionSyncing custom tables requires that sync tables are set up properly. In some cases, the sync data needs to be reset to allow that.Resolution
Remove the custom table option from the sync profile, then do a sync to confirm that the error goes away.
Remove the custom table from the Manage Custom Table Configuration settings (found on the sync profile page).
Remove the custom table's tracking table on the destination side of the sync.
Delete and recreate the custom table on the dest...
-
DescriptionWhen you try to install Service Update 9.00 SP2, an error occurs:
A newer patch update has already been installed on this CMS400 site. The patch will now close... CauseThe value of
InstallVersion
in
Ektron.ASM.EktronServices40.exe.config
is missing 0 in front of the .2. making the installer think it is a higher version. Resolution
Go to C:\Program Files (x86)\Ektron\EktronWindowsService40
Edit Ektron.ASM.EktronServices40.exe.config
Replace <add key="Instal...
-
Description
If sync is automatically restarting after restarting the Ektron Windows Service, see below to prevent that.
Resolution
Stop the Ektron Windows Service on the syncing servers and any connected load balanced servers.
Select the Top 1000 rows from the scheduler table of the sending and receiving databases.
Look at the scheduledesc tab.
If any of them still show as running when they should be completed, update them as follows.UPDATE SchedulerSET scheduledesc = 'com...
-
DescriptionEktron's eSync security certificates are used to ensure secured communication between servers. Here is more information for troubleshooting, generating, and verifying security certificates. They're tied to server hardware, server hostname, and IP address. If any of these settings were to change, certificates would need to be regenerated and swapped between sync servers as necessary. ResolutionHow To: Completely Remove eSync Certificates
Ensuring Sync Certificate Values are c...
-
DescriptionEsync errors out with Root Element is missing CauseThe most common cause of this issue is that the hard drive partition has run out of hard drive space. This causes the serverinfo.xml or serverinfo85.xml file to end up blank as there is no more hard drive space to save updates to either file. ResolutionTo fix this problem, insert 3 lines in the serverinfo.xml or serverinfo85.xml file. Follow these steps.
1. Clean up hard drive space until you have free space equal to 2....
-
Description
In some cases you may see the following error when creating a sync relationship.
"No security certificates were found for synchronization."
Below are the possible culprits and resolutions.
Resolution
Culprit #1: Security certificates have never been generated or were generated incorrectly. To verify check your site folder for 3 files named like '%_SyncClient%'. If these files are not present or their timestamps do not match the same files in the EktronWin...